DwgObject Constructor (ViewBase, Point, String, EmbeddedObjectAttributes)

Creates a new DwgObject instance using the specified attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public DwgObject(
	ViewBase view,
	Point insertionPoint,
	string fileName,
	EmbeddedObjectAttributes attributes
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view to be used.
insertionPoint
Type: Tekla.Structures.Geometry3dPoint
The insertion point to be used.
fileName
Type: SystemString
The filename to be used.
attributes
Type: Tekla.Structures.DrawingEmbeddedObjectAttributes
The attributes to be used.
Exceptions
ExceptionCondition
FileNotFoundExceptionThrown if the specified file does not exist.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next