Operation Class

Operations for drawing objects.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Drawing.OperationsOperation

Namespace:  Tekla.Structures.Drawing.Operations
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public class Operation

The Operation type exposes the following members.

Constructors
  NameDescription
Public methodOperation
Initializes a new instance of the Operation class
Top
Methods
  NameDescription
Public methodStatic memberCode exampleMergeMarks
Merges given marks objects.

NOTE!! Merge requires the original mark content to be similar and of same type. Operation does not support associative notes, mark sets or template content.

Public methodStatic memberCode exampleSortObjectsByPresentationOrder
Sorts objects relatively by presentation order from active drawing. Result is used to define relative drawing order of objects which are on top of each other. Last object from the list is drawn on top of all objects.
Public methodStatic memberCode exampleSplitMarks
Splits given marks to original marks.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next