BaseRebarGroup Class

The BaseRebarGroup class is an abstract base class that represents reinforcing bar group classes. The reinforcing bar groups derived from the base group are the rebar group, the circled rebar group and the curved rebar group.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class BaseRebarGroup : Reinforcement

The BaseRebarGroup type exposes the following members.

Properties
  NameDescription
Public propertyEndFromPlaneOffset
The end offset value from the part surface.
Public propertyEndHook
The hook at the end of the reinforcing bar.
Public propertyEndPoint
The end point of the direction in which the bars are distributed.
Public propertyExcludeType
Defines which bars to omit from the group. The options are:
  • EXCLUDE_TYPE_NONE
  • EXCLUDE_TYPE_FIRST
  • EXCLUDE_TYPE_LAST
  • EXCLUDE_TYPE_BOTH
Public propertyFromPlaneOffset
The offset value from the part surface applied in both sides.
(Overrides ReinforcementFromPlaneOffset.)
Public propertySize
The size of the reinforcement.
Public propertySpacings
The spacing value(s). If the type of the spacing is SPACING_TYPE_EXACT_NUMBER Spacings has only one value that defines the number of the reinforcing bars.
Public propertySpacingType
The type of spacing. The options are (BaseRebarGroup.RebarGroupSpacingTypeEnum.):
  • SPACING_TYPE_UNDEFINED
  • SPACING_TYPE_EXACT_SPACINGS
  • SPACING_TYPE_EXACT_NUMBER
  • SPACING_TYPE_TARGET_SPACE
  • SPACING_TYPE_EXACT_SPACE_FLEX_AT_START
  • SPACING_TYPE_EXACT_SPACE_FLEX_AT_END
  • SPACING_TYPE_EXACT_SPACE_FLEX_AT_BOTH
  • SPACING_TYPE_EXACT_SPACE_FLEX_AT_MIDDLE
Public propertyStartFromPlaneOffset
The start offset value from the part surface.
Public propertyStartHook
The hook at the beginning of the reinforcing bar.
Public propertyStartPoint
The start point of the direction in which the bars are distributed.
Top
Methods
  NameDescription
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next