GraphicObjectHatchAttributes Class

The GraphicObjectHatchAttributes class contains hatch attributes for graphic object hatches.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class GraphicObjectHatchAttributes : HatchAttributes

The GraphicObjectHatchAttributes type exposes the following members.

Properties
  NameDescription
Public propertyAngle
The angle in which to draw the hatch.
(Inherited from HatchAttributes.)
Public propertyBackgroundColor
The background color of the hatch.
(Inherited from HatchAttributes.)
Public propertyColor
The color of the hatch.
(Inherited from HatchAttributes.)
Public propertyDrawBackgroundColor
Sets whether the background color will be enabled or disabled for the hatch. See also: BackgroundColor.
(Inherited from HatchAttributes.)
Public propertyFactorType
The type of the hatch factor.
(Inherited from HatchAttributes.)
Public propertyName
The name of the hatch. If an empty string is given as hatch name it will become "None".
(Inherited from HatchAttributes.)
Public propertyOffsetX
The offset from the origin in the X-direction.
Public propertyOffsetY
The offset from the origin in the Y-direction.
Public propertyScaleX
The scale value of the hatch in the X-direction.
(Inherited from HatchAttributes.)
Public propertyScaleY
The scale value of the hatch in the Y-direction.
(Inherited from HatchAttributes.)
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next