DrawingObject Class

The DrawingObject class is an abstract base class for all the objects in the drawing. All drawing objects have a database identifier and belong to some view.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class DrawingObject : DatabaseObject, 
	IIsEqual, IRelatedObjects

The DrawingObject type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Gets or sets the attributes of the current object. Only attributes of the same type as the object are allowed.
Top
Methods
  NameDescription
Public methodGetDrawing
Gets the drawing where the drawing object is.
Public methodGetRelatedObjects
Gets the related objects of the current object.
Public methodGetRelatedObjects(Type)
Gets the related objects of the current object that are of certain types.
Public methodGetView
Gets the view where the drawing object is.
Public methodIsEqual
Compares the current object with the given object. Checks every field of both objects for equality.
Public methodToString
Changes the string presentation of the drawing object.
(Overrides ObjectToString.)
Top
See Also
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingDatabaseObject
    Tekla.Structures.DrawingDrawingObject
      Tekla.Structures.DrawingDetailMark
      Tekla.Structures.DrawingDimensionBase
      Tekla.Structures.DrawingDimensionLink
      Tekla.Structures.DrawingDimensionSetBase
      Tekla.Structures.DrawingEmbeddedObjectBase
      Tekla.Structures.DrawingGraphicObject
      Tekla.Structures.DrawingLeaderLine
      Tekla.Structures.DrawingLevelMark
      Tekla.Structures.DrawingLinkBase
      Tekla.Structures.DrawingMarkBase
      Tekla.Structures.DrawingModelObject
      Tekla.Structures.DrawingPlugin
      Tekla.Structures.DrawingSectionMarkBase
      Tekla.Structures.DrawingSymbol
      Tekla.Structures.DrawingText
      Tekla.Structures.DrawingViewBase
      Tekla.Structures.DrawingWeldMark
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next