DrawingObject Class

The DrawingObject class is an abstract base class for all the objects in the drawing. All drawing objects have a database identifier and belong to some view.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class DrawingObject : DatabaseObject, 
	IIsEqual, IRelatedObjects

The DrawingObject type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Gets or sets the attributes of the current object. Only attributes of the same type as the object are allowed.
Public propertyQueryReturnValue
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.)
Top
Methods
  NameDescription
Public methodDelete
Deletes the instance from the database.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(ListString, DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDrawing
Gets the drawing where the drawing object is.
Public methodGetIntegerUserProperties(DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetIntegerUserProperties(ListString, DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetRelatedObjects
Gets the related objects of the current object.
Public methodGetRelatedObjects(Type)
Gets the related objects of the current object that are of certain types.
Public methodGetStringUserProperties(DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetStringUserProperties(ListString, DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Double)
Gets a double property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Int32)
Gets an integer property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, String)
Gets a string property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetView
Gets the view where the drawing object is.
Public methodInsert
Inserts the object instance into the database. The inserted instance must be of a real type.
(Inherited from DatabaseObject.)
Public methodIsEqual
Compares the current object with the given object. Checks every field of both objects for equality.
Public methodIsSameDatabaseObject
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.)
Public methodModify
Modifies the instance in the database.
(Inherited from DatabaseObject.)
Public methodSelect
Selects the object instance from the database.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodToString
Changes the string presentation of the drawing object.
(Overrides ObjectToString.)
Top
See Also
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingDatabaseObject
    Tekla.Structures.DrawingDrawingObject
      Tekla.Structures.DrawingDetailMark
      Tekla.Structures.DrawingDimensionBase
      Tekla.Structures.DrawingDimensionLink
      Tekla.Structures.DrawingDimensionSetBase
      Tekla.Structures.DrawingEmbeddedObjectBase
      Tekla.Structures.DrawingGraphicObject
      Tekla.Structures.DrawingLeaderLine
      Tekla.Structures.DrawingLevelMark
      Tekla.Structures.DrawingLinkBase
      Tekla.Structures.DrawingMarkBase
      Tekla.Structures.DrawingModelObject
      Tekla.Structures.DrawingPlugin
      Tekla.Structures.DrawingSectionMarkBase
      Tekla.Structures.DrawingSymbol
      Tekla.Structures.DrawingText
      Tekla.Structures.DrawingViewBase
      Tekla.Structures.DrawingWeldMark
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next