ContourPoint Class

The ContourPoint class defines a point with possible chamfering information, used, for example, to define a contour plate.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ContourPoint : Point

The ContourPoint type exposes the following members.

Constructors
  NameDescription
Public methodContourPoint
Creates a new contour point instance.
Public methodContourPoint(Point, Chamfer)
Creates a new contour point using the given point and chamfer.
Top
Properties
  NameDescription
Public propertyChamfer
The chamfer for the contour point.
Top
Methods
  NameDescription
Public methodCompareTo
Compares two points. To use binarysearch somekind of sorting should be used.
(Inherited from Point.)
Public methodEquals
Returns true if the current object and the given object are equal.
(Inherited from Point.)
Public methodGetHashCode
Returns a hash code for the point. Notice, in extremely rare cases, you might not get the same hash code for two points even though they are considered equal! This should, however, happen only in extremely rare cases!
(Inherited from Point.)
Public methodSetPoint
Sets the point's coordinates for the contour point.
Public methodToString
Formats the point into a string.
(Inherited from Point.)
Public methodTranslate
Translates the point using the given vector.
(Inherited from Point.)
Public methodZero
Zeros all the members of the point.
(Inherited from Point.)
Top
Fields
  NameDescription
Public fieldX
The X-coordinate of the point.
(Inherited from Point.)
Public fieldY
The Y-coordinate of the point.
(Inherited from Point.)
Public fieldZ
The Z-coordinate of the point.
(Inherited from Point.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next