ContourPoint Class

The ContourPoint class defines a point with possible chamfering information, used, for example, to define a contour plate.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ContourPoint : Point

The ContourPoint type exposes the following members.

Constructors
  NameDescription
Public methodContourPoint
Creates a new contour point instance.
Public methodContourPoint(Point, Chamfer)
Creates a new contour point using the given point and chamfer.
Top
Properties
  NameDescription
Public propertyChamfer
The chamfer for the contour point.
Top
Methods
  NameDescription
Public methodSetPoint
Sets the point's coordinates for the contour point.
Top
Fields
  NameDescription
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next