MarkSet Class

The MarkSet class defines mark set objects that contain several mark objects merged to one mark set.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class MarkSet : MarkBase

The MarkSet type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Gets or sets the mark set attributes.
Top
Methods
  NameDescription
Public methodDelete
Calls the system to delete the object.
(Overrides DatabaseObjectDelete.)
Public methodInsert
Mark sets cannot be inserted.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodModify
Calls the system to update/modify the object.
(Overrides DatabaseObjectModify.)
Public methodSelect
Calls the system to select and retrieve the object.
(Overrides DatabaseObjectSelect.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next