GraphicsDrawerDrawLineSegment Method (Point, Point, Color)

Draws a temporary line segment in the currently active rendered view.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public bool DrawLineSegment(
	Point Point1,
	Point Point2,
	Color Color
)

Parameters

Point1
Type: Tekla.Structures.Geometry3dPoint
The first point of the line.
Point2
Type: Tekla.Structures.Geometry3dPoint
The second point of the line.
Color
Type: Tekla.Structures.Model.UIColor
The color of the line. The transparency value of the color is ignored.

Return Value

Type: Boolean
True on success.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next