StructuresFieldAttribute Class

The StructuresFieldAttribute class is used for mapping a database attribute to a data field that the plug-in uses in execution. The attribute is initialized from the custom attribute [StructuresField(attributeName)] in the plug-in source. In the plug-in the data field must be public and the type must be double, integer or string.
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.PluginsStructuresFieldAttribute

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
public sealed class StructuresFieldAttribute : Attribute

The StructuresFieldAttribute type exposes the following members.

Constructors
  NameDescription
Public methodStructuresFieldAttribute
The custom attribute [StructuresField(attributeName)] uses this to map a database attribute to a data field that the plug-in uses in execution. This is not to be used by itself.
Top
Properties
  NameDescription
Public propertyAttributeName
The name of the attribute.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next