BinaryFilterExpression Constructor (BooleanFilterExpression, BooleanOperatorType, BooleanConstantFilterExpression)

Initializes a new instance of the BinaryFilterExpression class.

Namespace:  Tekla.Structures.Filtering
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public BinaryFilterExpression(
	BooleanFilterExpression Left,
	BooleanOperatorType Oper,
	BooleanConstantFilterExpression Right
)

Parameters

Left
Type: Tekla.Structures.FilteringBooleanFilterExpression
The left operand of the filter expression.
Oper
Type: Tekla.Structures.FilteringBooleanOperatorType
The operator of the filter expression.
Right
Type: Tekla.Structures.FilteringBooleanConstantFilterExpression
The right operand of the filter expression.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when a null filter expression is specified.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next