OBB Constructor (Point, Vector, Double)

Initializes a new instance of the OBB class.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public OBB(
	Point center,
	Vector[] axis,
	double[] extent
)

Parameters

center
Type: Tekla.Structures.Geometry3dPoint
Center point of the OBB.
axis
Type: Tekla.Structures.Geometry3dVector
Three element array of unit-length vectors parallel the axis of the OBB.
extent
Type: SystemDouble
Three element array of the OBB extents (half-lengths of the edges).
Exceptions
ExceptionCondition
ArgumentExceptionThrown when initialization fails.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next