PluginAttribute Class

The PluginAttribute class is used for storing the name of the plug-in to the system. The attribute is initialized from the custom attribute [Plugin("PluginName")] in the plug-in source.
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.PluginsPluginAttribute

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
public sealed class PluginAttribute : Attribute

The PluginAttribute type exposes the following members.

Constructors
  NameDescription
Public methodPluginAttribute
The custom attribute [Plugin("PluginName")] uses this to store the name to the system. This is not to be used by itself.
Top
Properties
  NameDescription
Public propertyName
The name of the plug-in in the system.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next