Rotation3D Class

Represents 3d rotation of object.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.GeometryRotation3D

Namespace:  Tekla.Structures.Model.Geometry
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class Rotation3D

The Rotation3D type exposes the following members.

Constructors
  NameDescription
Public methodRotation3D
Initializes a new instance of the Rotation3D class.
Public methodRotation3D(Vector, Vector)
Initializes a new instance of the Rotation3D class.
Top
Properties
  NameDescription
Public propertyAxisX
Gets the X direction.
Public propertyAxisY
Gets the Y direction.
Public propertyAxisZ
Gets the Z direction.
Top
Methods
  NameDescription
Public methodEquals
Compares with another rotation.
Public methodStatic memberFromZRotation
Creates Rotation3D which represents rotation around the Z axis.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next