MaterialCatalog Class

The MaterialCatalog class represents a group of controls to select materials using the material catalog.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public class MaterialCatalog : UserControl

The MaterialCatalog type exposes the following members.

Constructors
  NameDescription
Public methodMaterialCatalog
Initiates a new instance of the control.
Public methodMaterialCatalog(String)
Creates a new instance of the MaterialCatalog and will select the material (if available) in the tree.
Top
Properties
  NameDescription
Public propertyButtonText
Gets and sets the text of the button control.
Public propertySelectedMaterial
Gets the selected material in the control.
Top
Events
  NameDescription
Public eventSelectClicked
The SelectClicked event is raised when the Select button is clicked.
Public eventSelectionDone
The SelectionDone event is raised when the selection has been done.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next