LayoutAttributes Class

The LayoutAttributes class contains attributes for controlling the drawing layout.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class LayoutAttributes : AttributesBase

The LayoutAttributes type exposes the following members.

Constructors
  NameDescription
Public methodLayoutAttributes Obsolete.
Creates a new layout attributes instance that loads standard attributes.
Public methodLayoutAttributes(String) Obsolete.
Creates a new layout attributes instance that loads drawing layout attributes from the specified attribute file.
Public methodLayoutAttributes(Drawing)
Creates a new layout attributes instance that loads standard attributes.
Public methodLayoutAttributes(String, Drawing)
Creates a new layout attributes instance that loads drawing layout attributes from the specified attribute file.
Top
Properties
  NameDescription
Public propertyAutoSizeOptions
Gets or sets the auto size options that control the drawing sheet size. Setting this property will change the SizeDefinitionMode to AutoSize.
Public propertyListHiddenObjectsInTemplates
Gets or sets the property for controlling whether to list hidden objects in templates.
Public propertySheetSize
Gets or sets the sheet size. Setting this property will change the SizeDefinitionMode to SpecifiedSize.
Public propertySizeDefinitionMode
Gets or sets the size definition mode.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).)
Public methodLoadAttributes
Loads drawing layout attributes from the specified attribute file.
(Overrides AttributesBaseLoadAttributes(String).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next