ViewViewShorteningAttributes Class

The ViewShorteningAttributes class sets the shortening attributes for the view. If CutParts is set to true, the other values are applied. If it is false, none of the other values matter.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingGenericAttributesBase
    Tekla.Structures.DrawingViewViewShorteningAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ViewShorteningAttributes : GenericAttributesBase

The ViewViewShorteningAttributes type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyCutParts
Defines whether cut parts are enabled (true) or disabled (false).
Public propertyCutPartType
Defines cut part type. Not used if CutParts is false.
Public propertyCutSkewParts
Defines whether cut skewed parts are enabled (true) or disabled (false).
Public propertyMinimumLength
The minimum cut part length.
Public propertyOffset
The space between the cut parts.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next