BaseWeld Class

The BaseWeld abstract class defines a weld between two model objects.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class BaseWeld : ModelObject

The BaseWeld type exposes the following members.

Properties
  NameDescription
Public propertyAdditionalSizeAbove
Gets or sets the additional size above for combination welds.
Public propertyAdditionalSizeBelow
Gets or sets the additional size below for combination welds.
Public propertyAngleAbove
Gets or sets the angle above.
Public propertyAngleBelow
Gets or sets the angle below.
Public propertyAroundWeld
Gets or sets a value indicating whether the weld is an around weld (true) or an edge weld (false).
Public propertyConnectAssemblies
Gets or sets a value indicating whether to connect a part or an assembly as a secondary part (false) or as a sub-assembly (true).
Public propertyContourAbove
Gets or sets the contour above.
Public propertyContourBelow
Gets or sets the contour below.
Public propertyEffectiveThroatAbove
Gets or sets the effective throat above.
Public propertyEffectiveThroatBelow
Gets or sets the effective throat below.
Public propertyElectrodeClassification
Gets or sets the weld electrode classification.
Public propertyElectrodeCoefficient
Gets or sets the electrode strength coefficient.
Public propertyElectrodeStrength
Gets or sets the electrode strength.
Public propertyFinishAbove
Gets or sets the finish above.
Public propertyFinishBelow
Gets or sets the finish below.
Public propertyIncrementAmountAbove
Gets or sets the increment amount above.
Public propertyIncrementAmountBelow
Gets or sets the increment amount below.
Public propertyIntermittentType
Gets or sets the weld intermittent type.
Public propertyLengthAbove
Gets or sets the length above.
Public propertyLengthBelow
Gets or sets the length below.
Public propertyMainObject
Gets or sets the main part of the weld.
Public propertyNDTInspection
Gets or sets the NDT inspection level.
Public propertyPitchAbove
Gets or sets the pitch above.
Public propertyPitchBelow
Gets or sets the pitch below.
Public propertyPlacement
Gets or sets the weld placement.
Public propertyPrefixAboveLine
Gets or sets the size prefix above the line.
Public propertyPrefixBelowLine
Gets or sets the size prefix below the line.
Public propertyPreparation
Gets or sets the weld preparation.
Public propertyProcessType
Gets or sets the process type.
Public propertyReferenceText
Gets or sets the reference text.
Public propertyRootFaceAbove
Gets or sets the root face above.
Public propertyRootFaceBelow
Gets or sets the root face below.
Public propertyRootOpeningAbove
Gets or sets the root opening above.
Public propertyRootOpeningBelow
Gets or sets the root opening below.
Public propertySecondaryObject
Gets or sets the secondary part of the weld.
Public propertyShopWeld
Gets or sets a value indicating whether the weld is a shop weld (true) or a site weld (false).
Public propertySizeAbove
Gets or sets the size above.
Public propertySizeBelow
Gets or sets the size below.
Public propertyStandard Obsolete.
Gets or sets the weld detail/standard.
Public propertyStitchWeld Obsolete.
Gets or sets a value indicating whether the weld is stitched (true) or not stitched (false).
Public propertyTypeAbove
Gets or sets the type above.
Public propertyTypeBelow
Gets or sets the type below.
Public propertyWeldNumber
Gets the weld number.
Public propertyWeldNumberPrefix
Gets or sets the weld number prefix.
Top
Methods
  NameDescription
Public methodGetSolid
Method for getting the weld solid.
Public methodGetWeldGeometries
Method for getting weld seam geometries. Every result represents one individual seam geometry in current weld.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next