BaseWeld Class

The BaseWeld abstract class defines a weld between two model objects.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class BaseWeld : ModelObject

The BaseWeld type exposes the following members.

Properties
  NameDescription
Public propertyAdditionalSizeAbove
Gets or sets the additional size above for combination welds.
Public propertyAdditionalSizeBelow
Gets or sets the additional size below for combination welds.
Public propertyAngleAbove
Gets or sets the angle above.
Public propertyAngleBelow
Gets or sets the angle below.
Public propertyAroundWeld
Gets or sets a value indicating whether the weld is an around weld (true) or an edge weld (false).
Public propertyConnectAssemblies
Gets or sets a value indicating whether to connect a part or an assembly as a secondary part (false) or as a sub-assembly (true).
Public propertyContourAbove
Gets or sets the contour above.
Public propertyContourBelow
Gets or sets the contour below.
Public propertyEffectiveThroatAbove
Gets or sets the effective throat above.
Public propertyEffectiveThroatBelow
Gets or sets the effective throat below.
Public propertyElectrodeClassification
Gets or sets the weld electrode classification.
Public propertyElectrodeCoefficient
Gets or sets the electrode strength coefficient.
Public propertyElectrodeStrength
Gets or sets the electrode strength.
Public propertyFinishAbove
Gets or sets the finish above.
Public propertyFinishBelow
Gets or sets the finish below.
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIncrementAmountAbove
Gets or sets the increment amount above.
Public propertyIncrementAmountBelow
Gets or sets the increment amount below.
Public propertyIntermittentType
Gets or sets the weld intermittent type.
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyLengthAbove
Gets or sets the length above.
Public propertyLengthBelow
Gets or sets the length below.
Public propertyMainObject
Gets or sets the main part of the weld.
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyNDTInspection
Gets or sets the NDT inspection level.
Public propertyPitchAbove
Gets or sets the pitch above.
Public propertyPitchBelow
Gets or sets the pitch below.
Public propertyPlacement
Gets or sets the weld placement.
Public propertyPrefixAboveLine
Gets or sets the size prefix above the line.
Public propertyPrefixBelowLine
Gets or sets the size prefix below the line.
Public propertyPreparation
Gets or sets the weld preparation.
Public propertyProcessType
Gets or sets the process type.
Public propertyReferenceText
Gets or sets the reference text.
Public propertyRootFaceAbove
Gets or sets the root face above.
Public propertyRootFaceBelow
Gets or sets the root face below.
Public propertyRootOpeningAbove
Gets or sets the root opening above.
Public propertyRootOpeningBelow
Gets or sets the root opening below.
Public propertySecondaryObject
Gets or sets the secondary part of the weld.
Public propertyShopWeld
Gets or sets a value indicating whether the weld is a shop weld (true) or a site weld (false).
Public propertySizeAbove
Gets or sets the size above.
Public propertySizeBelow
Gets or sets the size below.
Public propertyStandard Obsolete.
Gets or sets the weld detail/standard.
Public propertyStitchWeld Obsolete.
Gets or sets a value indicating whether the weld is stitched (true) or not stitched (false).
Public propertyTypeAbove
Gets or sets the type above.
Public propertyTypeBelow
Gets or sets the type below.
Public propertyWeldNumber
Gets the weld number.
Public propertyWeldNumberPrefix
Gets or sets the weld number prefix.
Top
Methods
  NameDescription
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the instance from the model database.
(Inherited from ModelObject.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetSolid
Method for getting the weld solid.
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodGetWeldGeometries
Method for getting weld seam geometries. Every result represents one individual seam geometry in current weld.
Public methodInsert
Inserts the model object instance into the model database.
(Inherited from ModelObject.)
Public methodModify
Modifies the model instance in the model database.
(Inherited from ModelObject.)
Public methodSelect
Selects the model object instance from the model database.
(Inherited from ModelObject.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next