SaveLoadHelpKeyword Property

Gets or sets the HelpKeyword that the help file should be opened for. If you do not provide a HelpKeyword and HelpUrl is not set, the default start page for Tekla Structures Help viewer is displayed.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public string HelpKeyword { get; set; }

Property Value

Type: String
Examples
If you would like to show for example the topic in the following location: "C:\MyApp\Sample.chm::/SubBook.chm::/MainPage.htm", the HelpKeyword would be "SubBook.chm::/MainPage.htm". If you are using the HelpProvider class to provide pop-up or online help for controls, you can get the keyword by calling HelpProvider1.GetHelpKeyword(this). If you would like to use Tekla Structures Help Viewer, you can do so by specifying HelpKeyword as "Filename" without extension and not setting the HelpUrl.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next