ImageListComboBox Class

The ImageListComboBox class represents a combo box control that can contain images from an ImageList control.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public sealed class ImageListComboBox : UserControl

The ImageListComboBox type exposes the following members.

Constructors
  NameDescription
Public methodImageListComboBox
Initializes a new instance of the ImageListComboBox class.
Top
Properties
  NameDescription
Public propertyDefaultValue
Gets or sets the default value in the image combo box. If the value is not found, SelectedItem is used instead.
Public propertyHoverColor
Gets or sets the hover color of the combo box.
Public propertyImageList
Gets or sets the ImageList that contains the images to be displayed in the combo box. Recommended image file formats are JPG and BMP.
Public propertySelectedIndex
Gets or sets the selected index of the image in the image combo box.
Public propertySelectedItem
Gets or sets the selected image in the image combo box. If the image is not found, SelectedIndex is used instead.
Public propertyToolTipText
Gets or sets the tool tip text.
Top
Methods
  NameDescription
Public methodCode exampleRefreshOptionList
Refreshes the option list content.
Top
Events
  NameDescription
Public eventImageListComboBoxMouseWheel
The ImageListComboBoxMouseWheel event is triggered just after the mouse wheel has been activated on top of the combo box.
Public eventImageListComboBoxSelectedIndexChanged
The ImageListComboBoxSelectedIndexChanged event is triggered just after the selected index has been changed in the image combo box.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next