ReinforcementBase Class

The ReinforcementBase class contains methods related to reinforcements. A reinforcement is a drawing object derived from a model object. It represents a drawing reinforcement that has a reference to the actual reinforcement in the model database.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class ReinforcementBase : ModelObject

The ReinforcementBase type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Top
Methods
  NameDescription
Public methodDelete
Deletes the drawing reinforcement from the current drawing database.
(Overrides DatabaseObjectDelete.)
Public methodInsert
Inserts the drawing reinforcement into the current drawing database. NOT YET IMPLEMENTED.
(Overrides DatabaseObjectInsert.)
Public methodModify
Modifies the drawing reinforcement in the current drawing database.
(Overrides DatabaseObjectModify.)
Public methodSelect
Selects the drawing reinforcement from the current drawing database.
(Overrides DatabaseObjectSelect.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next