PrinterItemEnumerator Class

The PrinterItemEnumerator class allows to loop through the catalog printer items.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsPrinterItemEnumerator

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class PrinterItemEnumerator : IEnumerator

The PrinterItemEnumerator type exposes the following members.

Properties
  NameDescription
Public propertyCurrent
Returns a printer item instance of the current element.
Top
Methods
  NameDescription
Public methodGetSize
Returns the total amout of items.
Public methodMoveNext
Moves to the next item in the enumerator.
Public methodReset
Resets the enumerator to the beginning.
Top
Examples
The following example returns true if an item with the name PDFactoryA3 has been found:
using Tekla.Structures.Catalogs;

public class Example
{
       public bool Example1()
       {
           bool Result = false;

           CatalogHandler CatalogHandler = new CatalogHandler();

           if (CatalogHandler.GetConnectionStatus())
           {
               PrinterItemEnumerator PrinterItemEnumerator = CatalogHandler.GetPrinterItems();

               while (PrinterItemEnumerator.MoveNext())
               {
                   PrinterItem PrinterItem = PrinterItemEnumerator.Current as PrinterItem;

                   if (PrinterItem.Name == "PDFactoryA3")
                   {
                       Result = true;
                       break;
                   }
               }
           }

           return Result;
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next