PolycurveGeometryBuilderAppend Method (Arc)

Appends an arc to the geometry list

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public PolycurveGeometryBuilder Append(
	Arc arc
)

Parameters

arc
Type: Tekla.Structures.Geometry3dArc
Geometry to append

Return Value

Type: PolycurveGeometryBuilder
The builder itself
Exceptions
ExceptionCondition
ArgumentExceptionThrown if input geometry is not connected to the polycurve
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next