TreeViewDialog Class

The TreeViewDialog class represents a "template" of a tree view dialog.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public class TreeViewDialog : ApplicationFormBase

The TreeViewDialog type exposes the following members.

Constructors
  NameDescription
Public methodTreeViewDialog
Initializes a new instance of the TreeViewDialog class.
Top
Properties
  NameDescription
Public propertyLocalization
The localization instance for the dialog. Each dialog has its own localization instance that has read the localization files needed for that dialog.
(Inherited from FormBase.)
Top
Methods
  NameDescription
Public methodApplyValues
Loads the dialog values from a file and performs Apply on the loaded values. To match the files to a certain dialog, the file suffix is set as the dialog type's name.
(Inherited from FormBase.)
Public methodGetConnectionStatus
Returns true if a proper connection to the Tekla Structures process has been established. Currently, there's no way to re-establish the connection.
(Inherited from FormBase.)
Public methodInitializeForm
Prepares the data storage for the dialog and scans through the fields.
(Inherited from FormBase.)
Public methodLoadValues
Loads the dialog values from a file. To match the files to a certain dialog, the file suffix is set as the dialog type's name.
(Inherited from FormBase.)
Public methodModifyValues
Loads the dialog values from a file and performs Modify on the loaded values. To match the files to a certain dialog, the file suffix is set as the dialog type's name.
(Inherited from FormBase.)
Public methodSaveValues
Serializes the dialog values to an xml file.
(Inherited from FormBase.)
Public methodCode exampleSetAttributeValue
Sets a value for the given control. When the dialog is not shown, setting a property directly for a control (such as textBox1.Text = "text") will not work for controls that have a Tekla Structures AttributeTypeName set. This method is going to have to be used to set the value.
(Inherited from FormBase.)
Public methodShowForm
Displays the form.
(Inherited from FormBase.)
Public methodUpdateValues Obsolete.
Rereads and updates all the field values on the form.
(Inherited from FormBase.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next