Localization Class

The Localization class is for translating strings in .NET dialogs.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public class Localization : MarshalByRefObject

The Localization type exposes the following members.

Constructors
  NameDescription
Public methodLocalization
Creates a new localization instance.
Public methodLocalization(String, String)
Creates a new localization instance.
Top
Properties
  NameDescription
Public propertyStatic memberDefaultLocalizationFile
The path and name of the default localization file.
Public propertyStatic memberDefaultLocalizationPath Obsolete.
The path and directory name where to find localization files.
Public propertyLanguage
Gets or sets the language that is currently used in Tekla Structures.
Top
Methods
  NameDescription
Public methodStatic memberGetLocalizationFileFullPath
Returns localization file if found from environment
Public methodGetText
Gets the translation for the current language. The translations are searched with the given identifier string.
Public methodLoadAidFile
Loads the localization strings from an aid file. Several files may be used concurrently, just call LoadAidFile for each file. The translations are searched in the loading order and the first match is returned.
Public methodLoadAilFile
Loads the localization strings from an ail file. Several files may be used concurrently, just call LoadAilFile for each file. The translations are searched in the loading order and the first match is returned.
Public methodLoadFile
Loads the localization strings from a file. Several files may be used concurrently, just call LoadFile for each file. The translations are searched in the loading order and the first match is returned. The method uses the extension of the filename to identify the file type (".xml", ".aid" or ".ail").
Public methodLoadXMLFile
Loads the localization strings from an xml file. Several files may be used concurrently, just call LoadXMLFile for each file. The translations are searched in the loading order and the first match is returned.
Public methodLocalize(ApplicationSettingsBase)
Localizes application settings.
Public methodLocalize(Control)
Localizes a control recursively.
Public methodLocalize(MenuItem)
Localizes a MenuItem control recursively.
Public methodLocalizeToolTip
Localizes a ToolTip control.
Public methodRegisterLocalizationCallback
Registers a localization callback which is used to translate the registered control types.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next