ICurve Interface

Interface that represents an abstract curved geometry defined by a set of points. This interface is intended to be the base class of 3D curves.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public interface ICurve : IEquatable<ICurve>

The ICurve type exposes the following members.

Properties
  NameDescription
Public propertyEndPoint
Gets the end point of the curve. May be the same as StartPoint if the curve is closed.
Public propertyLength
Gets the length of the curve
Public propertyStartPoint
Gets the start point of the curve
Top
Methods
  NameDescription
Public methodClone
Returns a deep copy of the geometry
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next