EventsModelObjectChangedDelegate Delegate

The delegate to use for changed model objects. ModelObject inside ChangeData contains only identifier information. If properties need to be checked, Select() for object is required.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public delegate void ModelObjectChangedDelegate(
	List<ChangeData> Changes
)

Parameters

Changes
Type: System.Collections.GenericListChangeData
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next