BindPropertyNameEditor Class

The BindPropertyNameEditor class provides a user interface for selecting a property for the attribute binding.
Inheritance Hierarchy
SystemObject
  System.Drawing.DesignUITypeEditor
    Tekla.Structures.DialogBindPropertyNameEditor

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public class BindPropertyNameEditor : UITypeEditor

The BindPropertyNameEditor type exposes the following members.

Constructors
  NameDescription
Public methodBindPropertyNameEditor
Initializes a new instance of the BindPropertyNameEditor class
Top
Methods
  NameDescription
Public methodEditValue
Edits the specified object's value using the editor style indicated by the GetEditStyle method.
(Overrides UITypeEditorEditValue(ITypeDescriptorContext, IServiceProvider, Object).)
Public methodGetEditStyle
Gets the editor style used by the EditValue method.
(Overrides UITypeEditorGetEditStyle(ITypeDescriptorContext).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next