OperationDisplayPrompt Method

Displays a message in the status bar.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public static bool DisplayPrompt(
	string Message
)

Parameters

Message
Type: SystemString
The message to display.

Return Value

Type: Boolean
True if the message could be displayed.
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when the Message is null.
Remarks
Prompts

Tekla Structures prefixes the given prompt with "prompt_" and looks for a translation in the prompts.ail file. If the translation (e.g. "prompt_Pick_first_position") is not found in the prompts.ail file, the prompt string is displayed as such. This feature can be used to give already translated strings to the picker.

See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next