PreferredTextPlacingTypes Class

The PreferredTextPlacingTypes class contains the available preferred text placing types. These are allowed to be used for texts.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingPreferredTextPlacingTypes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public static class PreferredTextPlacingTypes

The PreferredTextPlacingTypes type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAlongLinePlacingType
The object is placed using the along line placing.
Public methodStatic memberBaseLinePlacingType
The object is placed using the base line placing.
Public methodStatic memberBaseLineWithArrowAtEndPointPlacingType
The object is placed using the base line placing. The line is drawn and will have an arrow at the end point.
Public methodStatic memberBaseLineWithArrowAtStartPointPlacingType
The object is placed using the base line placing. The line is drawn and will have an arrow at the start point.
Public methodStatic memberLeaderLinePlacingType
The object is placed with a leader line.
Public methodStatic memberPointPlacingType
The object is placed at one point (the insertion point) without any additional placing options.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next