PluginPropertyFileLocationAttribute Constructor

Initializes a new instance of the PluginPropertyFileLocationAttribute class, for a file with provided filename suffix.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
public PluginPropertyFileLocationAttribute(
	string suffix,
	string subdirectory
)

Parameters

suffix
Type: SystemString
File suffix to register. Must contain the dot, such as ".ExamplePlugin.Data.txt". Should be as specific as possible.
subdirectory
Type: SystemString
The model folder subdirectory where the attribute should be searched for.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next