Weld Class

The Weld class represents a normal weld in the model. A normal weld has a main part and a secondary part.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Weld : BaseWeld

The Weld type exposes the following members.

Constructors
  NameDescription
Public methodWeld
Creates a new weld instance.
Top
Properties
  NameDescription
Public propertyDirection
Defines the Weld edge search direction normalized to length 1000.0. Overrides Position if set.
Public propertyPosition
Defines the position. Use of Direction is preferred over this.
Top
Methods
  NameDescription
Public methodDelete
Deletes the weld instance with the given identifier from the model database.
(Overrides ModelObjectDelete.)
Public methodGetLogicalWeld
Gets the logical weld where the weld belongs. Returns false if the weld does not belong to any logical weld.
Public methodInsert
Inserts the weld into the model database. All the attributes must be set.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing weld in the model database to match the current one. The modification cannot be done if the weld is a part of a logical weld.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a weld from the model database. The weld identifier must be set.
(Overrides ModelObjectSelect.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Point Beam1P1 = new Point(   0, 12000, 0);
           Point Beam1P2 = new Point(3000, 12000, 0);

           Point Beam2P1 = new Point(3000, 12000, 0);
           Point Beam2P2 = new Point(3000, 18000, 0);

           Beam Beam1 = new Beam(Beam1P1, Beam1P2);
           Beam Beam2 = new Beam(Beam2P1, Beam2P2);

           Beam1.Profile.ProfileString = "HEA400";
           Beam1.Finish = "PAINT";
           Beam1.Name = "Beam 1";
           Beam2.Name = "Beam 2";

           Beam1.Insert();
           Beam2.Insert();

           Weld Weld = new Weld();
           Weld.MainObject = Beam1;
           Weld.SecondaryObject = Beam2;
           Weld.TypeAbove = BaseWeld.WeldTypeEnum.WELD_TYPE_SQUARE_GROOVE_SQUARE_BUTT;

           Weld.Insert();

           Weld.LengthAbove = 12;
           Weld.TypeBelow = BaseWeld.WeldTypeEnum.WELD_TYPE_SLOT;

           Weld.Modify();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next