Weld Class

The Weld class represents a normal weld in the model. A normal weld has a main part and a secondary part.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Weld : BaseWeld

The Weld type exposes the following members.

Constructors
  NameDescription
Public methodWeld
Creates a new weld instance.
Top
Properties
  NameDescription
Public propertyAdditionalSizeAbove
Gets or sets the additional size above for combination welds.
(Inherited from BaseWeld.)
Public propertyAdditionalSizeBelow
Gets or sets the additional size below for combination welds.
(Inherited from BaseWeld.)
Public propertyAngleAbove
Gets or sets the angle above.
(Inherited from BaseWeld.)
Public propertyAngleBelow
Gets or sets the angle below.
(Inherited from BaseWeld.)
Public propertyAroundWeld
Gets or sets a value indicating whether the weld is an around weld (true) or an edge weld (false).
(Inherited from BaseWeld.)
Public propertyConnectAssemblies
Gets or sets a value indicating whether to connect a part or an assembly as a secondary part (false) or as a sub-assembly (true).
(Inherited from BaseWeld.)
Public propertyContourAbove
Gets or sets the contour above.
(Inherited from BaseWeld.)
Public propertyContourBelow
Gets or sets the contour below.
(Inherited from BaseWeld.)
Public propertyDirection
Defines the Weld edge search direction normalized to length 1000.0. Overrides Position if set.
Public propertyEffectiveThroatAbove
Gets or sets the effective throat above.
(Inherited from BaseWeld.)
Public propertyEffectiveThroatBelow
Gets or sets the effective throat below.
(Inherited from BaseWeld.)
Public propertyElectrodeClassification
Gets or sets the weld electrode classification.
(Inherited from BaseWeld.)
Public propertyElectrodeCoefficient
Gets or sets the electrode strength coefficient.
(Inherited from BaseWeld.)
Public propertyElectrodeStrength
Gets or sets the electrode strength.
(Inherited from BaseWeld.)
Public propertyFinishAbove
Gets or sets the finish above.
(Inherited from BaseWeld.)
Public propertyFinishBelow
Gets or sets the finish below.
(Inherited from BaseWeld.)
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIncrementAmountAbove
Gets or sets the increment amount above.
(Inherited from BaseWeld.)
Public propertyIncrementAmountBelow
Gets or sets the increment amount below.
(Inherited from BaseWeld.)
Public propertyIntermittentType
Gets or sets the weld intermittent type.
(Inherited from BaseWeld.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyLengthAbove
Gets or sets the length above.
(Inherited from BaseWeld.)
Public propertyLengthBelow
Gets or sets the length below.
(Inherited from BaseWeld.)
Public propertyMainObject
Gets or sets the main part of the weld.
(Inherited from BaseWeld.)
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyNDTInspection
Gets or sets the NDT inspection level.
(Inherited from BaseWeld.)
Public propertyPitchAbove
Gets or sets the pitch above.
(Inherited from BaseWeld.)
Public propertyPitchBelow
Gets or sets the pitch below.
(Inherited from BaseWeld.)
Public propertyPlacement
Gets or sets the weld placement.
(Inherited from BaseWeld.)
Public propertyPosition
Defines the position. Use of Direction is preferred over this.
Public propertyPrefixAboveLine
Gets or sets the size prefix above the line.
(Inherited from BaseWeld.)
Public propertyPrefixBelowLine
Gets or sets the size prefix below the line.
(Inherited from BaseWeld.)
Public propertyPreparation
Gets or sets the weld preparation.
(Inherited from BaseWeld.)
Public propertyProcessType
Gets or sets the process type.
(Inherited from BaseWeld.)
Public propertyReferenceText
Gets or sets the reference text.
(Inherited from BaseWeld.)
Public propertyRootFaceAbove
Gets or sets the root face above.
(Inherited from BaseWeld.)
Public propertyRootFaceBelow
Gets or sets the root face below.
(Inherited from BaseWeld.)
Public propertyRootOpeningAbove
Gets or sets the root opening above.
(Inherited from BaseWeld.)
Public propertyRootOpeningBelow
Gets or sets the root opening below.
(Inherited from BaseWeld.)
Public propertySecondaryObject
Gets or sets the secondary part of the weld.
(Inherited from BaseWeld.)
Public propertyShopWeld
Gets or sets a value indicating whether the weld is a shop weld (true) or a site weld (false).
(Inherited from BaseWeld.)
Public propertySizeAbove
Gets or sets the size above.
(Inherited from BaseWeld.)
Public propertySizeBelow
Gets or sets the size below.
(Inherited from BaseWeld.)
Public propertyStandard Obsolete.
Gets or sets the weld detail/standard.
(Inherited from BaseWeld.)
Public propertyStitchWeld Obsolete.
Gets or sets a value indicating whether the weld is stitched (true) or not stitched (false).
(Inherited from BaseWeld.)
Public propertyTypeAbove
Gets or sets the type above.
(Inherited from BaseWeld.)
Public propertyTypeBelow
Gets or sets the type below.
(Inherited from BaseWeld.)
Public propertyWeldNumber
Gets the weld number.
(Inherited from BaseWeld.)
Public propertyWeldNumberPrefix
Gets or sets the weld number prefix.
(Inherited from BaseWeld.)
Top
Methods
  NameDescription
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the weld instance with the given identifier from the model database.
(Overrides ModelObjectDelete.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetLogicalWeld
Gets the logical weld where the weld belongs. Returns false if the weld does not belong to any logical weld.
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetSolid
Method for getting the weld solid.
(Inherited from BaseWeld.)
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodGetWeldGeometries
Method for getting weld seam geometries. Every result represents one individual seam geometry in current weld.
(Inherited from BaseWeld.)
Public methodInsert
Inserts the weld into the model database. All the attributes must be set.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing weld in the model database to match the current one. The modification cannot be done if the weld is a part of a logical weld.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a weld from the model database. The weld identifier must be set.
(Overrides ModelObjectSelect.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Point Beam1P1 = new Point(   0, 12000, 0);
           Point Beam1P2 = new Point(3000, 12000, 0);

           Point Beam2P1 = new Point(3000, 12000, 0);
           Point Beam2P2 = new Point(3000, 18000, 0);

           Beam Beam1 = new Beam(Beam1P1, Beam1P2);
           Beam Beam2 = new Beam(Beam2P1, Beam2P2);

           Beam1.Profile.ProfileString = "HEA400";
           Beam1.Finish = "PAINT";
           Beam1.Name = "Beam 1";
           Beam2.Name = "Beam 2";

           Beam1.Insert();
           Beam2.Insert();

           Weld Weld = new Weld();
           Weld.MainObject = Beam1;
           Weld.SecondaryObject = Beam2;
           Weld.TypeAbove = BaseWeld.WeldTypeEnum.WELD_TYPE_SQUARE_GROOVE_SQUARE_BUTT;

           Weld.Insert();

           Weld.LengthAbove = 12;
           Weld.TypeBelow = BaseWeld.WeldTypeEnum.WELD_TYPE_SLOT;

           Weld.Modify();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next