ReportTemplateElement Class

The ReportTemplateElement class represents a template in the Tekla Structures template library.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingElementBase
    Tekla.Structures.DrawingReportTemplateElement

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ReportTemplateElement : ElementBase

The ReportTemplateElement type exposes the following members.

Constructors
  NameDescription
Public methodReportTemplateElement
Creates a new report template element instance with the default template.
Public methodReportTemplateElement(TemplateInfo)
Creates a new report template element instance with the given template.
Top
Properties
  NameDescription
Public propertyTemplate
The template.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next