RebarLegSurfaceObject Class

The RebarLegSurfaceObject class represents a polymesh surface for generating rebar legs in a RebarSet.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class RebarLegSurfaceObject : SurfaceObject

The RebarLegSurfaceObject type exposes the following members.

Constructors
  NameDescription
Public methodRebarLegSurfaceObject
Initializes a new instance of the RebarLegSurfaceObject class.
Top
Properties
  NameDescription
Public propertyAdditionalOffset
Gets or sets the user defined offset of the rebar legs from the leg surface object.
Public propertyLayerNumber
Gets or sets the layer number of the leg surface object.
Public propertyRebarSet
Gets or sets the RebarSet to which the leg surface object belongs.
Top
Methods
  NameDescription
Public methodInsert
Inserts the leg surface object into the model database.
(Overrides SurfaceObjectInsert.)
Public methodModify
Modifies the existing leg surface object in the model database to match the current one.
(Overrides SurfaceObjectModify.)
Public methodSelect
Selects the leg surface object from the model database. The identifier must be set.
(Overrides SurfaceObjectSelect.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
    public void Example1(Vector[] vertices, int[][] outerWires, IDictionary<int, int[][]> innerWires)
    {
        var beam = new Beam();
        // Set Beam properties (code omitted)...
        beam.Insert();

        var rebarSet = new RebarSet();
        // Set RebarSet properties (code omitted)...
        rebarSet.Insert();

        var legSurface = new RebarLegSurfaceObject();
        legSurface.Polymesh = new FacetedBrep(vertices, outerWires, innerWires);
        legSurface.Father = beam;
        legSurface.RebarSet = rebarSet;
        legSurface.LayerNumber = 1;
        legSurface.AdditionalOffset = 25.0;
        legSurface.Insert();
    }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next