RebarLegSurfaceObject Class

The RebarLegSurfaceObject class represents a polymesh surface for generating rebar legs in a RebarSet.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class RebarLegSurfaceObject : SurfaceObject

The RebarLegSurfaceObject type exposes the following members.

Constructors
  NameDescription
Public methodRebarLegSurfaceObject
Initializes a new instance of the RebarLegSurfaceObject class.
Top
Properties
  NameDescription
Public propertyAdditionalOffset
Gets or sets the user defined offset of the rebar legs from the leg surface object.
Public propertyClass
Gets or sets the class of the surface object.
(Inherited from SurfaceObject.)
Public propertyCreateHoles
Gets or sets a value indicating whether CreateHoles parameter of the surface object.
(Inherited from SurfaceObject.)
Public propertyFather
Gets or sets the father object of the surface object. The father can be set only before the Insert(), otherwise exception is thrown.
(Inherited from SurfaceObject.)
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyLayerNumber
Gets or sets the layer number of the leg surface object.
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyName
Gets or sets the name of the surface object.
(Inherited from SurfaceObject.)
Public propertyPolymesh
Gets or sets the surface geometry brep.
(Inherited from SurfaceObject.)
Public propertyRebarSet
Gets or sets the RebarSet to which the leg surface object belongs.
Public propertyType
Gets or sets the type of the surface object.
(Inherited from SurfaceObject.)
Top
Methods
  NameDescription
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the model object from the model database.
(Inherited from SurfaceObject.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodInsert
Inserts the leg surface object into the model database.
(Overrides SurfaceObjectInsert.)
Public methodModify
Modifies the existing leg surface object in the model database to match the current one.
(Overrides SurfaceObjectModify.)
Public methodSelect
Selects the leg surface object from the model database. The identifier must be set.
(Overrides SurfaceObjectSelect.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
    public void Example1(Vector[] vertices, int[][] outerWires, IDictionary<int, int[][]> innerWires)
    {
        var beam = new Beam();
        // Set Beam properties (code omitted)...
        beam.Insert();

        var rebarSet = new RebarSet();
        // Set RebarSet properties (code omitted)...
        rebarSet.Insert();

        var legSurface = new RebarLegSurfaceObject();
        legSurface.Polymesh = new FacetedBrep(vertices, outerWires, innerWires);
        legSurface.Father = beam;
        legSurface.RebarSet = rebarSet;
        legSurface.LayerNumber = 1;
        legSurface.AdditionalOffset = 25.0;
        legSurface.Insert();
    }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next