Angle Class

Provides support for angles using either the current Tekla Structures units, or user defined units
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DatatypeAngle

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
public class Angle : IFormattable, IComparable<Angle>, 
	IEquatable<Angle>

The Angle type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberCurrentUnitType
Gets or sets the Tekla Structures current angle type
Public propertyCurrentUnitValue
Gets the value of the angle in the current unit
Public propertyStatic memberDecimalPlaces
Gets the number of decimal places used for angles.
Public propertyDegrees
Gets the angle value in degrees
Public propertyRadians
Gets the angle value in radians
Top
Methods
  NameDescription
Public methodCompareTo
Compares this angle with another angle
Public methodEquals
Checks for approximate angle equality
Public methodStatic memberFromCurrentUnit
Creates an angle given in the current unit type
Public methodStatic memberFromDegrees
Creates an angle from a value in degrees
Public methodStatic memberFromRadians
Creates an angle from a value in radians
Public methodStatic memberParse(String)
Parses the given text as an angle in the current unit type
Public methodStatic memberParse(String, IFormatProvider)
Parses the given text as an angle in the current unit type
Public methodStatic memberParse(String, IFormatProvider, AngleUnitType)
Parses the given text as an angle in the current unit type
Public methodToString
Converts the represented angle to a string in the current units
(Overrides ObjectToString.)
Public methodToString(AngleUnitType)
Converts the represented angle to a string in the given units
Public methodToString(String, IFormatProvider)
Converts the represented angle to a string with the given parameters
Public methodToString(String, IFormatProvider, AngleUnitType)
Converts the represented angle to a string with the given parameters
Public methodStatic memberTryParse(String, Angle)
Parses the given text as an angle in the current unit type
Public methodStatic memberTryParse(String, IFormatProvider, Angle)
Parses the given text as an angle in the current unit type
Public methodStatic memberTryParse(String, IFormatProvider, AngleUnitType, Angle)
Parses the given text as an angle in the current unit type
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next