PartPartAttributes Class

The PartAttributes class is the attributes class for the part.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingAttributesBase
    Tekla.Structures.DrawingPartPartAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class PartAttributes : AttributesBase

The PartPartAttributes type exposes the following members.

Constructors
  NameDescription
Public methodPartPartAttributes
Creates a new default part attributes instance that loads standard attributes.
Public methodPartPartAttributes(String)
Creates a new part attributes instance that loads the specified attributes.
Top
Properties
  NameDescription
Public propertyCustomPresentation
Custom presentation GUID to be applied to the object type
Public propertyDrawCenterLine
True if the center line is drawn.
Public propertyDrawChamfers
True if chamfers are drawn.
Public propertyDrawConnectingSideMarks
True if connecting side marks are drawn.
Public propertyDrawHiddenLines
True if hidden lines are drawn.
Public propertyDrawOrientationMark
True if the orientation mark is drawn.
Public propertyDrawOwnHiddenLines
True if own hidden lines are drawn.
Public propertyDrawPopMarks
True if pop marks are drawn.
Public propertyDrawReferenceLine
True if the reference line is drawn.
Public propertyFaceHatch
The hatch type of the face hatch.
Public propertyHiddenLines
The line type of hidden lines.
Public propertyPartialProfileLength
Gets or sets the partial profile length.
Public propertyPartialProfileOffset
Gets or sets the partial profile offset.
Public propertyReferenceLine
The line type of the reference line.
Public propertyRepresentation
The representation of the part.
Public propertySectionFaceHatch
The hatch type of the section face hatch.
Public propertySymbolOffset
The symbol offset.
Public propertyVisibleLines
The line type of visible lines.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next