GenericAttributesBase Class

The GenericAttributesBase class is a base class that shared attributes among many classes use.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingGenericAttributesBase
    More...

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class GenericAttributesBase : IIsEqual

The GenericAttributesBase type exposes the following members.

Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
Top
See Also
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingGenericAttributesBase
    Tekla.Structures.DrawingArrowheadAttributes
    Tekla.Structures.DrawingDetailMarkTagsAttributes
    Tekla.Structures.DrawingDimensionSetBaseAttributesCombinedDimensionAttributes
    Tekla.Structures.DrawingDimensionSetBaseAttributesDimensionExaggerationAttributes
    Tekla.Structures.DrawingDimensionSetBaseAttributesDimensionFormatAttributes
    Tekla.Structures.DrawingDimensionSetBaseAttributesDimensionPlacingAttributes
    Tekla.Structures.DrawingDimensionSetBaseAttributesDimensionTextAttributes
    Tekla.Structures.DrawingDPMPrinterAttributes
    Tekla.Structures.DrawingFontAttributes
    Tekla.Structures.DrawingHatchAttributes
    Tekla.Structures.DrawingLineTypeAttributes
    Tekla.Structures.DrawingLinkFrameAttributes
    Tekla.Structures.DrawingPlacingAttributes
    Tekla.Structures.DrawingPlacingDirectionAttributes
    Tekla.Structures.DrawingPlacingDistanceAttributes
    Tekla.Structures.DrawingPlacingQuarterAttributes
    Tekla.Structures.DrawingPrintAttributes
    Tekla.Structures.DrawingSectionMarkBaseSectionMarkSymbol
    Tekla.Structures.DrawingSectionMarkBaseSectionMarkTagsAttributes
    Tekla.Structures.DrawingTemplateInfo
    Tekla.Structures.DrawingUnitAttributes
    Tekla.Structures.DrawingViewViewMarkTagsAttributes
    Tekla.Structures.DrawingViewViewShorteningAttributes
    Tekla.Structures.DrawingViewMarkBasicSymbolAttributes
    Tekla.Structures.DrawingViewMarkBasicTagAttributes
    Tekla.Structures.DrawingWeldMarkSeamVisibilityAttributes
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next