InsidePartHorizontalOrWithLeaderLinePlacingType Class

The InsidePartHorizontalOrWithLeaderLinePlacingType class defines a placing type that places the object using the base line placing as the first option. If there is no room for the first option the fallback option will be used. The fallback option is placing the object with a leader line. The base line used is in the middle of the part, aligned with the part. In addition the object will be rotated to be horizontal in the drawing.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingPreferredPlacingTypeBase
    Tekla.Structures.DrawingInsidePartHorizontalOrWithLeaderLinePlacingType

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class InsidePartHorizontalOrWithLeaderLinePlacingType : PreferredPlacingTypeBase

The InsidePartHorizontalOrWithLeaderLinePlacingType type exposes the following members.

Constructors
  NameDescription
Public methodInsidePartHorizontalOrWithLeaderLinePlacingType
Creates a new inside part horizontal or with leader line placing type instance.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next