Assembly Class

The Assembly class defines a single manufacturing unit: objects that are bolted or welded together in the workshop. An assembly has a main part and secondary assemblables attached to it. The number of secondaries is limited to 2048. Hierarchical assemblies can also have subassemblies attached to them and they can have a parent assembly instance.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Assembly : ModelObject

The Assembly type exposes the following members.

Constructors
  NameDescription
Public methodAssembly
Creates a new assembly instance.
Top
Properties
  NameDescription
Public propertyAssemblyNumber
Defines the numbering in the assembly sense. If the members are empty and zero, the main part attributes are used.
Public propertyName
The name of the assembly.
Top
Methods
  NameDescription
Public methodAdd(ArrayList)
Adds an array list of given assemblable instances to the assembly. For assemblies use Add(Assembly Assembly). Notice that adding other than assembly instances will actually assume that you are adding objects to a cast unit assembly.
Public methodAdd(Assembly)
Adds a new subassembly for the assembly instance.
Public methodAdd(IAssemblable)
Adds the given assemblable instance to the assembly. Notice that adding other than assembly instances will assume that you are adding objects to a cast unit assembly.
Public methodCompareTo(Assembly)
Compares the instantiated assembly with another one.
Public methodDelete
Explodes the assembly instance.
(Overrides ModelObjectDelete.)
Public methodDeleteUserDefinedCoordSys
Deletes the assembly's user defined coordinate system, if it has one.
Public methodGetAssembly
Returns the assembly instance the assembly belongs to (null if none).
Public methodGetAssemblyType
Returns the type of the assembly.
Public methodGetFatherPour
Returns the pour that the assembly is directly associated to.
Public methodGetFatherPourUnit
Returns the pour unit that the bolt group is associated to.
Public methodGetMainObject
Selects and returns the main object of the assembly or null if none.
Public methodGetMainPart
Selects and returns the main part of the assembly or null if none.
Public methodGetSecondaries
Selects and returns all the secondary assemblables belonging to the assembly. The method replaces the old GetObjects() method. Notice that the number of secondaries is limited to 2048.
Public methodGetSubAssemblies
Selects and returns a list of subassemblies belonging to the assembly.
Public methodHasUserDefinedCoordSys
Returns whether the assembly has a user defined coordinate system.
Public methodInsert
Inserts the Assembly instance in the model. At the moment only rebar assemblies can be inserted. The main object of the assembly must be a Reinforcement or RebarSet. If the main rebar is not set (null), the main rebar will be automatically set to the secondary rebar with the biggest weight.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the assembly instance in the model.
(Overrides ModelObjectModify.)
Public methodRemove
Removes the given instance from the assembly. Before removing steel parts from an assembly all connecting workshop welds and bolts must be deleted.
Public methodSelect
Selects the assembly instance from the model. The identifier of the instance must be set.
(Overrides ModelObjectSelect.)
Public methodSetMainObject
Sets the main object of the assembly.
Public methodSetMainPart
Sets the main part of the assembly.
Public methodSetUserDefinedCoordSys
Set user defined assembly coordinate system. If set, GetCoordinateSystem will return this value.
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;
using System;

public class Example
{
       public void Example1()
       {
           Beam beam1 = new Beam(new Point(0,0,0), new Point(1000,0,0));
           Beam beam2 = new Beam(new Point(0,0,0), new Point(0,0,1000));

           beam1.Profile.ProfileString = "380*380";
           beam1.Material.MaterialString = "K40-1";

           beam2.Profile.ProfileString = "380*380";
           beam2.Material.MaterialString = "K40-1";

           beam1.Insert();
           beam2.Insert();

           Assembly assembly = beam1.GetAssembly();
           assembly.Add(beam2);

           if(!assembly.Modify())
               Console.WriteLine("Assembly Modify Failed!");
       }

       public void Example2()
       {
           // Create some rebars.
           var rebarSet = new RebarSet();
           var rebarGroup = new RebarGroup();
           var singleRebar = new SingleRebar();
           // Set rebar properties here (code omitted).
           rebarSet.Insert();
           rebarGroup.Insert();
           singleRebar.Insert();

           // Create a rebar assembly.
           var rebarAssembly = new Assembly();
           rebarAssembly.SetMainObject(rebarSet);
           rebarAssembly.Add(rebarGroup);
           rebarAssembly.Add(singleRebar);
           rebarAssembly.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next