AABBCollide Method

Checks if the current axis-aligned 3d bounding box collides with another given axis-aligned 3d bounding box. Both axis-aligned 3d bounding boxes need to be in the same coordinate system or in the same workplane, so that they are defined using the same axes.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public bool Collide(
	AABB Other
)

Parameters

Other
Type: Tekla.Structures.Geometry3dAABB
Another axis-aligned 3d bounding box to be used in the collision check.

Return Value

Type: Boolean
True if the axis-aligned 3d bounding boxes collide.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next