ModelViewEnumerator Class

The ModelViewEnumerator class is an enumerator class for model views. The enumerator enables model view items to be looped.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.UIModelViewEnumerator

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ModelViewEnumerator : IEnumerator

The ModelViewEnumerator type exposes the following members.

Properties
  NameDescription
Public propertyCount
Returns the number of views in the enumerator.
Public propertyCurrent
Returns the current view.
Public propertyCurrentViewId
Gets the current view identifier.
Top
Methods
  NameDescription
Public methodMoveNext
Moves to the next view in the enumerator.
Public methodReset
Resets the enumerator.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next