ModuleManager Class

The ModuleManager class handles the product model module configuration information: the information that defines what configuration the customer is currently running.
Inheritance Hierarchy
SystemObject
  Tekla.StructuresModuleManager

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public sealed class ModuleManager

The ModuleManager type exposes the following members.

Constructors
  NameDescription
Public methodModuleManager
Initializes a new instance of the ModuleManager class
Top
Properties
  NameDescription
Public propertyStatic memberAnalysisAndDesign
Indicates whether the Analysis and Design management is enabled.
Public propertyStatic memberCIPModeling
Indicates whether the CIP modeling is enabled.
Public propertyStatic memberConcreteDetailing
Indicates whether the concrete detailing is enabled.
Public propertyStatic memberConfiguration
The currently running configuration of Tekla Structures.
Public propertyStatic memberLoadModeling
Indicates whether the load modeling is enabled.
Public propertyStatic memberMultimaterialModeling
Indicates whether the multimaterial modeling is enabled.
Public propertyStatic memberRebarModeling
Indicates whether the rebar modeling is enabled.
Public propertyStatic memberSteelDetailing
Indicates whether the steel detailing is enabled.
Public propertyStatic memberTaskManagement
Indicates whether the task management is enabled.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next