DetailTypeAttribute Class

The DetailTypeAttribute class is used for storing the detail type. Based on the type the system will then position the detail in the creation. The attribute is initialized from the custom attribute [DetailType(DetailTypeEnum.END)] in the connection source.
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.PluginsDetailTypeAttribute

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
public sealed class DetailTypeAttribute : Attribute

The DetailTypeAttribute type exposes the following members.

Constructors
  NameDescription
Public methodDetailTypeAttribute(Int32)
The custom attribute [DetailType()] uses this to store the type of the detail to the system. This is not to be used by itself.
Public methodDetailTypeAttribute(DetailTypeEnum)
The custom attribute [DetailType()] uses this to store the type of the detail to the system. This is not to be used by itself.
Top
Properties
  NameDescription
Public propertyType
The custom attribute [DetailType()] uses this to store the type of the detail to the system. This is not to be used by itself.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next