AnalysisDecomposedNodeLoad Class

The AnalysisDecomposedNodeLoad class contains information related to decomposed node loads.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisDecomposedNodeLoad : AnalysisDecomposedLoad

The AnalysisDecomposedNodeLoad type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisDecomposedNodeLoad
Initializes a new instance of the AnalysisDecomposedNodeLoad class.
Top
Properties
  NameDescription
Public propertyAnalysisLoadType
Gets or sets the type of the analysis decomposed load.
(Inherited from AnalysisDecomposedLoad.)
Public propertyAnalysisModelName
Gets or sets the analysis model name.
(Inherited from AnalysisObject.)
Public propertyAnalysisObjectType
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.)
Public propertyF
Gets or sets the force of the analysis decomposed node load.
Public propertyFatherObject2ID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObject2Type
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyFatherObjectID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObjectType
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyID
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.)
Public propertyM
Gets or sets the moment of the analysis decomposed node load.
Public propertyModelLoadGroupID
Gets or sets the identifier of the load group.
(Inherited from AnalysisDecomposedLoad.)
Public propertyModelLoadID
Gets or sets the identifier of the model load.
(Inherited from AnalysisDecomposedLoad.)
Public propertyObjectAttachedToID
Gets or sets the identifier of the object the load is attached to.
(Inherited from AnalysisDecomposedLoad.)
Public propertyObjectAttachedToType
Gets or sets the type of the object the load is attached to.
(Inherited from AnalysisDecomposedLoad.)
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next