ArrowheadAttributes Class

The ArrowheadAttributes class handles attributes related to arrowheads of different objects.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ArrowheadAttributes : GenericAttributesBase

The ArrowheadAttributes type exposes the following members.

Constructors
  NameDescription
Public methodArrowheadAttributes
Creates a new default arrowhead attributes instance. The default values are ArrowheadPositions.None, ArrowheadTypes.FilledArrow, height 2.0 and width 1.0.
Public methodArrowheadAttributes(ArrowheadPositions, ArrowheadTypes, Double, Double)
Creates a new arrowhead attributes instance with the given parameters.
Top
Properties
  NameDescription
Public propertyArrowPosition
The position of the arrowhead. The position is always ArrowheadPositions.Both for dimensions.
Public propertyHead
The type of the arrowhead.
Public propertyHeight
The height of the arrowhead.
Public propertyWidth
The width of the arrowhead.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next