API Namespaces

Namespaces

Tekla.Structural.ExpressoAddIn

Tekla Tedds Add-In's

Tedds Add-In's allow anyone with Microsoft .Net programming experience to extend the Tedds function library with their own custom functions. Creating an Add-In allows you to integrate Tedds with your existing in-house software applications or applications and services from other 3rd parties.

The Tekla.Structural.ExpressoAddIn namespace contains the classes and types required to create a Tedds Add-In

Tekla.Structural.InteropAssemblies.Tedds

Tekla Tedds Application API

The Tedds Application API allows you to automate tasks using the features of the Tedds Application. For example you can create a project, add new documents, calculate those documents and convert final output documentation to PDF format. You cannot directly provide input variables to a calculation using just the Tedds Application. However by using the Tedds Calculator you can generate input variables and pre-calculated output which can then be used with the Tedds Application to create Tedds documents.

The Tedds Application is an Out-of-process COM Server Tedds.exe which means it can be used from both 32-bit and 64-bit processes.

The Tekla.Structural.InteropAssemblies.Tedds namespace contains the classes and types required to use the Tedds Application API.

Tekla.Structural.InteropAssemblies.TeddsCalc

Tekla Tedds Calculator API

The Tedds Calculator is the application which performs the actual calculation processing, it can be used to evaluate single mathematical expressions or to evaluate complete calculations.

The Tedds Calculator is an Out-of-process COM Server TeddsCalc.exe which means it can be used from both 32-bit and 64-bit processes.

The Tekla.Structural.InteropAssemblies.TeddsCalc namespace contains the classes and types required to use the Tedds Calculator API.

Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Next